Archive

Archive for the ‘openSuse’ Category

Обновление openSUSE c 10.3 до 11

May 7th, 2008 5 comments

Решил провести чуточку экспериментов по обновлении openSUSE. Скажу сразу: если поломалось – я не виноват. Все манипуляции я делаю на виртуальной машите VirtualBOX и, возможно, в реальных условиях могут быть отличия.

Обновление 32-х битной 10.3 до ветки 11 Beta 1 (это последний релиз на это время) я решил провести при разных случаях:

  • обновление 10.3 с подключеным packman и update (все обновления стоят) с интернета
  • обновление 10.3 чистая и без обновлений с интернета.

Поссмотрим, что у меня получится. Read more…

В репозитарии Packman начинают собирать под openSUSE 11.0 и удаляют 10.0

April 30th, 2008 No comments

В связи с тем, что поддержка openSUSE 10.0 заканчивается в ноябре, в Packman, как сообщает ИнформБюро /dev/loki, решили не затягивать с этим делом и до конца недели избавится от остатков прошлого. Если кому-то повезло и у него десятка, могу посоветовать или проапгрейдится, или (уж если так дорога) собирать пакеты самому.

Но есть и хорошая новость – там же начали собирать пакеты для openSUSE 11.0, начиная с Beta1.

Categories: Linux, Novell, openSuse Tags:

openSUSE 11 Alpha3

March 19th, 2008 No comments

А вот и 11 с третьей Альфой вышла.

  • openSUSE 11 Alpha3 Screenshot
  • Скриншот openSUSE 11 Alpha3

Работает, но четвёртые КЭДЫ при загрузке выпадают с ошибкой. Может что-то со старых кед осталось, поссмотрю. Чуть изменили дизайн инсталлера, скриншоты которого можно проссмотреть на сайте.

Categories: Linux, openSuse Tags:

Compiz-Fussion 0.7.2

March 7th, 2008 No comments

Compiz-Fussion LogoСегодня в рассылке compiz-fussion анонсировали новый development release Compiz-Fussion. Эта версия будет служить основой для стабильной версии 0.8.0.

Новое в этом релизе:

Compiz

  • Поддержка переводов в gtk-window-decorator.
  • Added wrapable session functions to core. This allows to provide a full session save/restore in a plugin.
  • Обновлены переводы и, конечно, исправлены ошибки.

Compiz Fusion:

Новые плагины:

compiz-fusion-plugins-main:

  • session: общается с менеджером сессий (session manager) для согранения/восстановления состояния окон
  • bs: Изменяет яркость и насыщеность цветов с помощью кнопок или мыши
  • mousepoll: обеспечивает для системы и других плагинов данные о текущей позиции мыши
  • mag: обеспечивает лупу под курсором мышки в трёх режимах (simple/image overlay/fisheye)

compiz-fusion-plugins-extra:

  • 3d: добавляет глубину десктопа
  • loginout: обеспечивает простую реализацию анимации для входа и выхода с системы
  • maximumize: изменяет размер окна в зависимости от размера пустого места на экране
  • notification: показывает сообщения о ошибках с помощью libnotify
  • shelf: уменшает окно до заданого размера, для проссмотра всех окон за раз
  • showmouse: обрамляет указатель частицами-лучами мыши для тех, кто его не замечает :)

compiz-fusion-plugins-unsupported:

  • atlantis: показ аквариума внутри прозрачного куба

Так же есть usability изменения в ccsm.

Пакеты с новым Compiz Fusion уже существуют, а у нас обновятся в два часа ночи.

Categories: compiz, download, Linux, openSuse Tags:

Уж лучше застрелится, чем ждать

February 28th, 2008 No comments

Меня достало сидеть без плагинов в своём почтовике, особенно когда claws mail вышел 3.3.1, а у меня старый, без поддержки плагина сворачивания в трэй. И на сайте Packman`а для 10.2 уже выложили, а для openSuse 10.3 никто и не собрал. Так продолжатся не может! Я уже устал держать почтовик активным – хочу его в трэй! Буду пересобирать пакет!

Первое, что надо сделать – скачать src-пакет с сайта. Это не сложно.

Дальше просто вводим в консоле комманду:

rpmbuild –rebuild claws-mail-3.3.1-0.pm.0.src.rpm

Вот тут мне сразу рассказали, что я дурак у меня нет девел пакетов. Списочек выскочил маленький, но когда я попросил смарт поставить их, то по зависимостях он мне 70-80 пакетов нащитал! Но они маленькие и, в основном, с диска. Я качаю всё с интернета и мне это обошлось в 20 мегабайт безлимитного трафика.

Но. Это не весь список нужных пакетов. Когда я всё поставил и опять запустил комманду перепаковки пакета, стало понятно, что нехватает gettext-devel. Но это уже мелочи. Так что, если есть такие же “збоченці”, то ставьте и его.
После 5 минут курения, пересобраные пакеты появились в /usr/src/packages/RPMS/

зы. Если кому-то тоже надо claws-mail-3.3.1-0.pm.0.x86_64.rpm для OpenSUSE 10.3, то качайте на здоровье.

Categories: Linux, openSuse Tags:

Локальный Root на Linux

February 11th, 2008 4 comments

Сегодня ночью (или вчера) в сети появился код эксплоита для получения локального рута. Насколько я знаю, то уязвимости подвержены ядра c 2.6.17. На сегодняшний день выпущено ядро 2.6.24.2, в котором уязвимость уже профиксена. Получить рута от простого пользователя не сложно, имея код эксплоита, что и было проверено мной на машине:

wert2all@wert2all:~/tmp/exploid> uname -a
Linux wert2all 2.6.22.16-0.2-default #1 SMP 2008/02/01 19:36:55 UTC x86_64 x86_64 x86_64 GNU/Linux
wert2all@wert2all:~/tmp/exploid> gcc local_root.c -o local-root
wert2all@wert2all:~/tmp/exploid> ./local-root
-----------------------------------
 Linux vmsplice Local Root Exploit
 By qaaz
-----------------------------------
[+] mmap: 0x100000000000 .. 0x100000001000
[+] page: 0x100000000000
[+] page: 0x100000000038
[+] mmap: 0x4000 .. 0x5000
[+] page: 0x4000
[+] page: 0x4038
[+] mmap: 0x1000 .. 0x2000
[+] page: 0x1000
[+] mmap: 0x2b260abaf000 .. 0x2b260abe1000
[+] root
wert2all:~/tmp/exploid # whoami
root
wert2all:~/tmp/exploid #

Это печально, даже если учесть, что у некоторых он не срабатывает с первого раза. Пока апдейта для OpenSuSE нет, но после такого должно выйти быстренько.

Categories: Linux, openSuse, security, взлом Tags:

Репозитарии openSUSE в UA-IX

November 23rd, 2007 No comments

Сегодня добавил в cron linux.kiev.ua затягивание репозитария с Compiz и Packman для openSUSE 10.3. Все репозитарии будут находится тут. Кого интересует ещё что-то и надо всё это в UA-IX – обращайтесь. Мне не сложно, а mike@ говорил, что винтов вагон и тележка с кастрюлькой. Сегодня в 2 часа ночи обновятся репозитарий Пакмана и KDE3 c KDE4. В это же время, каждый день эта операция будет повторяться.

А теперь вопрос по-серёзней.

Кому-то надо исошки и пакман для 10.1 версии? Так же на сервере валяется SLICK и девятка. Насколько я знаю, то 9 уже новелом не суппортится, а 10.1 и подавно никому не нужна. Я предлагаю всё это старьё убить и оставить только (пока) исошки с 10.2. Винты есть, но оно никому не надо и лежит мёртвым грузом.

Комментарии висят на форуме, если не будут против, то через недельку-вторую я потру всё ненужное. А Пакманом пользуйтесь! ;)

Categories: compiz, download, KDE4, Linux, openSuse, suse, web Tags:

Чиним java VM

October 19th, 2007 5 comments

Сегодня утром просснулся с серьёзной мыслю напрограмить вагонетку кода, написать чуть не весь проэкт, над которым работаю. Потянулся, взял чашечку кофе дабы проснутся и в 9:50 уже был готов работать, что уж очень рано для меня. Скажу ещё то, что вчера ночью (или утро уже было) моя openЗЮЗЯ вытянула обновления java 1.6 с Eclipse, на что я не среагировал никак. Ну и что нам какие-то 70-100 метров при нашем анлиме ;)

Утро же получилось прекрассное, да и будущей жены сегодня день рождения (ПАЗДРАВЛЯЮ!!!), что не могдо не радовать. И что я получил? По клике на ярлыке Eclipse я получал фигу. Тоесть ничего не получал. Хм. А ну ка, консолька, скажи мне, кто на свете мог меня так обидеть?

wert2all@wert2all:~/public_html/talkfest/_db> eclipse
Cannot find java virtual machine, aborting.

Ну капец, как её нет, когда вчера обновилась?

После копания и пинания всего джавовского, догадался удалить предыдущую версию java. Удалять я люблю ;)

Потом следует запустить `update-alternatives –config java`

wert2all:/home/wert2all/public_html/talkfest/_db # update-alternatives --config java

There are 2 programs which provide `java'.Selection    Command

-----------------------------------------------

1        /usr/lib64/jvm/jre-1.4.2-gcj/bin/java

+    2        /usr/lib64/jvm/jre-1.6.0.u3-sun/bin/java

Enter to keep the default[*], or type selection number: 2

Using `/usr/lib64/jvm/jre-1.6.0.u3-sun/bin/java' to provide `java'.

wert2all:/home/wert2all/public_html/talkfest/_db #

Вот и почилили java. Вот так надо настраивать java в opensuse 10.3. Но карма уже прогнулась же.

Categories: Linux, openSuse Tags: , , , ,

Присматриваемся к openSUSE 10.3: Виртуализация

October 17th, 2007 No comments

opensuse logoНекоторые изменения в openSUSE 10.3 гарантируют, что если вы интересуетесь каким-то типом, ныне пополярной, виртуализации, то openSUSE как раз для вас. От Xen до VirtualBox, QEMU и KVM — они все есть в новой версии. Сегодня мы будем обсуждать некоторые с этих нововведений и разговаривать с Frank Kohler, Project-менеджером по виртуализации в SUSE, который поможет нам узнать немножечко больше. Read more…

Установка драйверов ATI/AMD и NVIDIA одним кликом

October 6th, 2007 3 comments

amd-ati.jpgЕсли вам повезло и вы счасливый обладатель openSUSE 10.3, недавно выпущеной в свет, то у вас есть возможность установить драйвера своей видео-карты в один клик. Конечно, если у вас Intel, то вам ещё больше повезло – устанавливать драйвера не надо, но для NVIDIA/AMD, в связи с лицензионными проблемами, устанавливать драйвера нужно вручную.

В этой версии дистрибутива репозиторий для NVIDIA почти прописан (нужно только его включить), то с ATI с драйверами очень плохо надо повозится. Но сегодня прочитал, как установить драйвера и для них.

Есть 2 пути – простой и очень простой. Начну с очень простого. Read more…

Categories: Linux, openSuse, suse, настройка Tags: